Why would I be getting TPS lag spikes every 30 seconds on a single player local client world? [closed]

I am using the AtLauncher with a modded Thaumcraft based world and keep getting a lag spike every 30 seconds that basically stops the world and it rushes to catch up. Turing on the Lagometer it shows it as TICK lag which I don't get since I am playing local on my machine not on a server.

Does anyone know a setting that might cause this?

Reading: minecraft lag on single player

View more: How To Ride A Llama In Minecraft 1.11, Minecraft 1

I am not running Thaumcraft machines constantly (they are too noisy) but I do have a fair number of golems. That is not my first thought for an cause because the golems are pretty random and the spike is fairly constant at 30 seconds. Event if I pull up the options menu and all mobs stop and time stands still the Lagometer still runs in the back ground and I still see the spikes.

Mod List: forge-1.7.10-10.13.2.1230-universal LibSandstone-1.0.0 CodeChickenLib-1.7.10-1.1.1.99-universal Deconstruction-Table-1.7.10 Reliquary-1.2 Carpenter's Blocks v3.3.4.1 Chisel-1.7.10-1.5.6 DeadlyWorld-1.7.10-1.0.2 twilightforest-1.7.10-2.3.2 Thaumcraft-1.7.10-4.2.3.5 Baubles-1.7.10-1.0.1.10 CodeChickenCore-1.7.10-1.0.4.29-universal NotEnoughItems-1.7.10-1.0.3.74-universal statues-1.7.10-2.1.4 AsieLib-1.7.10-0.3.8 Waila-1.5.5-1.7.10 EnchantView-v4.0.4 ThebombzenAPI-v2.4.1-mc1.7.2 OptiFine_1.7.10_HD_B5 Automagy-1.7.10-0.22.1 Single player TICK lag screen shot

Related: https aka ms remote connect code minecraft nintendo switch | WTBBLUE

Leave a Comment